For all those who have accidentally updated to 4.1 and then found they have updated their baseband, there is hope again for you!
Most people should know by now that Ultrasn0w does not support the latest carrier unlocks that were updated to 05.14.02 (iPhone 3G and 3GS) and 02.10.04 (iPhone 4) in iOS 4.1. If you did not update to iOS 4.1 using this tutorial here or somehow used The Pwnage Tool (which has not been released) or Sn0wbreeze, then you will be on the latest baseband.
MuscleNerd has again confirmed that there will be a carrier unlock made available for users sometime after iOS 4.2 has been released. Please read his tweet below: